Unable to install Permut8

Thomas Benecke728 views10 posts
  • Thomas Benecke

    Mac Pro (OS X v10.8.4)

    Ableton 8.4.1

    (latest) Microtonic, Synplant and Bitspeek installed

    A few days ago I just tried to install the Permut8 demo and ran into troubles. By some reason Permut8 won't install. The installation hangs on the screen where the progress bar appears and nothing happens (no disk or cpu activity).

    I redownloaded the installer, also restarted my system but no luck.

    Odd things I noticed that may be of interest:

    • The mounted dmg is really 102,4mb? see screenshot
    • I won't get to select a user account before I can start the installation. The installer only lists the option to "install for all users". Don't know if that's the way it's supposed to be.
    • Why does it say "skip" ("überspringen") on the button? Is the installer in progress of checking something? Also, pressing it disables it but doesn't do anything besides.



  • Fredrik Lidström


    Sounds and looks bad. Permut8 installer should not be that different from our other installers that seems to work on your system. When opening the dmg it runs a verification to make sure the file is not damaged, as that passes we can rule out that your file is damaged.

    1. Yes, the dmg is 102.4 Mb, but with a lot of free space on it, that is correct.
    1. You should get a normal login box after you clicked install where you have to authorize the installer to make changes to the system. Does the installation halt before you get this box?
    1. Good question. =)

    After you start the installer can you please go to the "Window" menu and enable the "Installer Log" window. Change it to "Show All Logs" and then start the installer. If you cannot find anything odd in the installer log that you can figure out what it is, just hit Save (if you can) and then send me the Installer Log. Post a link to it through http://soniccharge.com/email or attach it to a new post in support as they are hidden when posted.

  • Thomas Benecke

    Sorry for getting back so late, I didn't find the time to test again until now.

    I attached the installation log as I didn't find anything suspicious myself. And no, the installer does not really halt before the authorization box. Just a little loading for 1-2 seconds until it appears. After I authorize is where it halts.

    Also, maybe worth noting, pressing the strange "skip" button is not loged within the installation log.

  • Fredrik Lidström

    Missing your attachment.

  • Thomas Benecke

    Sorry, missed to hit that button. Here it is.

  • Fredrik Lidström

    We have looked at this and cannot figure out what is going wrong on your machine. There is obviously something going wrong in Apples Installer here. The next thing your installer should do is switch authorization level and a line in your log should say:

    Installer[4264]: Set authorization level to root for session

    What we do not understand is why our other installers are working for you but not Permut8. Did you run any of the other installers recently on your computer?

  • Thomas Benecke

    - Fredrik Lidström wrote:
    Did you run any of the other installers recently on your computer?

    Yes, I did so indeed.

    Just before I tried to install Permut (for the first time) on my system, I installed the latest version of Microtonic (and maybe also Synplant, not sure) as my version was out of date and I wanted to update my registered version (which did work without any problems).

    If I remember correctly, Microtonic came with some kind of new DRM or registration system?

  • Thomas Benecke

    So is there anything else I could or are you out of ideas too?

  • Fredrik Lidström

    We have not been able to reproduce the problem and we are running out of ideas. There is nothing special we are doing in our installers that should halt the installation that early in the process. We do display a dialog and launch the Authenticator, but that is later after the package installation is finished. So what you are experiencing is a strange halt in the middle of Apples Package Maker routines just before it should elevate your login.

    Did you run a disc scan and permission repair to make sure you do not have some access problems on your file system?

    If you have and it is still not working, let me know and I will email you a package and instructions on how to install everything manually.

  • Thomas Benecke

    Yes, my backup tool does repair the disc permissions on a regular basis. It would be nice if you could send me the manual installation instructions and files!

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.