µTonic keeps asking for the serial number

R.A.W.7 162 views18 posts
  • R.A.W.

    Hi there,
    I got an odd behaviour of µTonic. It keeps forgetting the registration every once in a while. I have to re-enter the serial that regularly, that I keep a txt containing the registration in my VST folder.

    Unfortunately I can't give more details on how to reproduce this.

    I hope this can be fixed soon or at least explained ;)

    Thanks in advance.

    µTonic v3.0.1
    Win7 Professional x64
    energyXT 2.6 and Ableton Live 8.2.6

  • Fredrik Lidström

    When our products "forgets" the registration it usually has to do with an access problem to the registry (Windows) or preference file (Mac).

    Please check if If you make any changes to the preference dialog in MicroTonic, is that information kept if you restart? If not, then for some reason, you do not have access rights to write to the registry as needed. If you are running under a restricted account, you could try to relax the restrictions temporarily until you registered MicroTonic (like setting your self as administrator).

    If you want to look into the problem in more detail, here is the path to the registry key:

    \HKEY_CURRENT_USER\Software\NuEdge Development\SonicCharge

  • R.A.W.

    Hi Fredrik,
    although I'm on Win7 I always run anything with admin rights. I also disabled the UAC on my machine. The registry key you mentioned is set and has two binary values, "Data" and "ssc2salt" and I guess one is supposed to contain the encoded registration.
    I just opened µTonic again after looking in the registry and it was in demo mode again. I entered the reg details and the "Data" value changed.. I will keep track of it the next few weeks.

    The odd thing is that it doesn't loose the reg always, for a few weeks everything is fine and one day it's gone out of the blue. I'm an IT professional and know my computer well ;) - µTonic is the only VST that does this, even Synplant doesn't seem to have that problem.

    Btw. I would prefer if the reg data and config was written to a file anyway - though I'm on Win, I really hate the registry stuff. ;)

  • R.A.W.

    Well, this is odd..

    Today I once again had to enter the reg info... and this time twice in a row. I was working in Ableton, inserted the µTonic Drum Rack which uses the multi-out version and was asked for the reg again. I just didn't enter them but closed Ableton.

    Then I fired up energyXT (with admin rights, context menu run as admin), opened the single out version, entered the reg, restarted energyXT and tried multi and single out versions and everything was fine. Then I started Ableton again and inserted the drum rack and I was asked for the reg again???!! I entered the reg, this time right away in Ableton and now it seems to work... well, at last for a few days..

    Is there any problem when using the single and multi out versions in turns?

    Btw.: I exported the registry entries before and after entering the reg data. If that helps I can email that to you.

    [edit]OK, it seems it has something to do with using different DAWs. In Ableton everything was fine first, then I tested energyXT and it was in demo again... as if the reg just counts for one DAW at a time..

    I can reproduce that everytime now.. regging in eXT->MT doesn't work in Ableton and the other way around[/edit]

  • Magnus Lidström

    Weirdness. Would love to see the registry entries thanks. Send them to support@soniccharge.com.

    The only incompatibility that we know of which erases the registration data was between version 1 and version 2 of MicroTonic. But version 3 uses a totally separate "chunk" for its registration data.

    Just for safety measure, could you please double-check that you only have version 3.0.1 installed and no other MicroTonic*.dll on your entire hard-drive.

    Haven't you beta-tested for us by the way? I recognize your handle. I can't rule out that a beta-version of MicroTonic could corrupt the registration data even if it is just scanned and never launched.

  • R.A.W.

    Hi Magnus,
    yes I beta-tested, but had XP back then. Now I got the version 3.0.1 final running on Win7 and no other MT dll is on my hard drive. I just sent the registry files.

    I really hope you can fix that because it starts to annoy me. ;)

  • R.A.W.

    Hi there!
    I'm back from my vacation (skiing - I want to go back there right now ;)) and I just started Opera which remembered this forum tab.
    Any news on this? Did you get some clues from my files?

  • R.A.W.

    Hi Magnus,
    any news?

  • R.A.W.

    Anything? It's been over 2 months now...

  • Magnus Lidström

    - R.A.W. wrote:
    Anything? It's been over 2 months now...

    Hey. I am really sorry. Time flies amazingly fast. I did check your registry data, but it didn't shed any new light on the matter. The only thing I could see was that the "demo dump" was unregistered and the "full dump" was registered. Apart from that all registry data was identical. It looks like MicroTonic has just unregistered itself, and the only occasion where that can happen is when it fails to validate the registration key. Either because the key data is invalid or because the "system identifier" has changed. Neither of which makes much sense to me under the circumstances you describe.

    My plan was to finish a MicroTonic 3.0.2 beta that you could try. As far as I remember I haven't changed anything concerning registration codes but the betas include traces that are helpful. However, as MT 3.0.2 was put on hold for some more urgent work, the only thing I can offer you right now is the beta of MT 3.0.1 that will send us the trace logs.

    I need to change the expiration date though, which means a few hours of rebuilding (I know, crazy). I'll get back to you tomorrow if I have a beta-build that works.

  • R.A.W.

    Hi Magnus, thanks for looking into this. I just sent you a PM.

  • R.A.W.

    Hi everyone and especially Magnus and Fredrik,
    thanks to great support including a special logging build for me, we figured it out eventually.

    It was (of course ;)) a system setting at my end: energyXT was running in Win XP compatibility mode (don't know why, didn't notice..), while all my other DAWs where running as native Win 7 applications. That made MT3 calculate different computer IDs for eXT and the other DAWs causing the need to reg MT3 everytime I fired it up inside eXT.

    So, thanks again for looking into this and figuring it out!!
    Milan aka R.A.W.

    • done-and-ready-to-be-closed *
  • Magnus Lidström

    Lesson of the day: don't use Windows XP compatibility mode.

    Still bad that MicroTonic (and all our products, and Addictive Drums as well for that matter) is sensitive about this. I will try to figure out a good way to get rid of this particular registry key for the computer id calculation. I would like to avoid having everyone forced to re-register all of our products just because we need to modify our computer id algorithm.

  • anonymous

    hey guys,

    I'm new on the forum but I have the exact same problem with my microtonic. I understand that you guys figured it out but from the messages here I cant really say what i have to do to make it stop. can someone please explain me how i can get rid of this ?

    EDIT: I tried the compatability by the way and that was not the problem in my case.

    thanks in advance

  • R.A.W.

    - Iwan van der Wijk wrote:
    EDIT: I tried the compatability by the way and that was not the problem in my case.

    well, then i can't help in this case. on my machine it was the compatibility setting of one of the DAWs. if that doesn't help on your end, it has to be something different.

  • anonymous

    - R.A.W. wrote:
    well, then i can't help in this case. on my machine it was the compatibility setting of one of the DAWs. if that doesn't help on your end, it has to be something different.

    yeah i tried to look into my fl studio files and it wasnt in compatiblity mode. doe you think it may be because of the settings of uTonic?

    and do you have any id if i can just uninstall uTonic and reinstall it. or will i then loose all my sounds in my projects?

    hope one of the admins can shed a little bit more light into this for me.

  • Richard Manning

    I've had to authenticate again to my current computer where I've authenticated several times in the past. The number of authorized computers continues to increase even though I'm authenticating to the same computer? Is there a way to unauthorize / de-authorize?

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.