9/8 time signature problem with drag&drop in Logic

Milenko Stanisic4 461 views6 posts
  • Users avatarMilenko Stanisic

    Hi guys,
    I am using Logic 8.5 on MacOS 10.5.8

    I'm new to MicroTonic, just been using it for a couple of weeks, and I love it! It is interesting, creative, and inspiring. Works very well and does what I expect it to do. So all is great! Except...

    Except, I can not figure out how to use MicroTonic with some of my 9/8 time signature songs (9/8 meter). What I did was to make my patterns using 9 steps length, and when I play them in MicroTonic it does exactly what I want - playing all patterns after each other in real 9/8 time signature. But the problem begins when I want to drag and drop MIDI to Logic track. The midi line I receive by doing that does not fit in bars at all. What it does is adding empty space in the end of a beat I made until it fits in a bar. I don't know if you got what I mean, but if my beat of 9 looks like this: 123456789 when I drag and drop MIDI in a track it becomes: 1234567890000000 (where zeros represents the empty space in midi track just to fill the bar). It fills up "empty space" as if I wanted to use all 16 steps in MicroTonic pattern. Of course, a midi file like that does not loop right, it does not fit rhythmically, and it doesn't fit the BPM. I tried to export patterns to audio files too, but it does the same: adding empty space in the end.


    Basically, my question is: can MicroTonic be used in such metrics as 5/4 7/8 or 9/8? And how can I export my patterns so it could be used in Logic? I am very grateful for any suggestions or help! Tack på förhand!
  • Users avatarMagnus Lidström

    Hi. I've done some quick tests now and from all I can tell the limitation lies in the host. For example, VSTHost (which has a MIDI-file player) loops odd time-signatures correctly, while Live "pads" the clips to whole 4/4 bars.

    When I export to audio I do not get the padding you speak of. Perhaps you have chosen the "append" tail mode? Please, try the "loop" mode for me and let me know if that works or not.

  • Users avatarMilenko Stanisic

    Hi Magnus, thank you for your answer.

    In the meantime I was experimenting, and after I changed "step rate" from 1/8T to 1/8 everything worked great :)
    MIDI track fits the bars in Logic perfectly and it loops exactly right. No "tail" in the end. (Of course, the song in Logic is in 9/8 metrics too)

    Also, exporting to audio in "loop" mode fits perfect.

    But making triplets in odd time-signatures will be hard to achieve..

    However I'm happy with this solution! It works for me :)

    Thanks for the truly great product!

  • Users avatarMagnus Lidström

    Great that you found a solution.

    - Misko Stanisic wrote:
    In the meantime I was experimenting, and after I changed "step rate" from 1/8T to 1/8 everything worked great :)

    I tried this too, but it didn't make a difference for me (with the hosts that actually pay attention to midi-file end position). 1/8T works as good as 1/8. With audio export as well.

  • Users avatarjohn burbank

    I had this problem with all my drag midi functions after I loaded 3.1 I found the same problem with the 1/8t being set so all my programs were coming out not synced! Once I changed to 1/8 all was fine :)

  • Users avatarMagnus Lidström

    - John Burbank wrote:
    I had this problem with all my drag midi functions after I loaded 3.1

    Also in Logic? With 3.1, did you mean MicroTonic 3.0.1? Is there any difference from 3.0?

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×