microtonic , renoise render to sample adds 1 /2 milliseconds

gentleclockdivider gentleclockdivider79 views5 posts
  • gentleclockdivider gentleclockdivider

    In my host Renoise , we have the option to render a note to sample ( this is an offline process and is basically a bounce function )
    Whenever a note is inserted that triggers microtonic and rendered to selection ( not using the built in sequencer ) , the rendered sample has 1 to 2 milliseconds of silence before it
    Afaik , this did happen with the previous versions
    At the moment I am using the demoversion of microtonic ( awaiting license transfer )

  • Magnus Lidström

    Microtonic has a buffer-size and latency of 64 samples that is reported to the host and should be compensated properly when rendering to audio. Is there a setting for latency-compensation in Renoise?

    We have not changed this in many years.

    There might be a slight inaccuracy when triggering via MIDI but this is usually down to a few samples only (in 44khz). I.e. microseconds, not milliseconds.

  • gentleclockdivider gentleclockdivider

    Right , I see
    Plugin delay compensation was turned of , hence the longer delay
    When turned on , the time is 0.8 ms

    pdc off.jpg

    pdc onn.jpg
  • Magnus Lidström

    It is still too much imo and I wonder why. In Ableton for instance I see a few samples delay max. That's like 0.05 ms. The attack in your screenshot does not look sharp enough. Is the attack-slider all the way down for this test? Also, turn off any eq when you test as there is always some group delay in minimum phase filters.

  • gentleclockdivider gentleclockdivider

    Oh boy , indeed the attack slider wasn't completely down
    With plugin delay compentation on , it's about 0.1 ms ..good enough for me.

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×